Product

【End of Support】OS Versions Lower than iOS 8

2017-09-25

Dear Customer,

In order to continue improving our service and your experience, we will be ending support for all Apple devices with iOS versions lower than 8 from November 2017. This is necessary in order to improve the stability and to add new features, all of which is not supported by older OS versions.

While users can continue to use previously installed, older versions of KKBOX on devices running iOS 8, we will no longer provide support for any issues encountered.

P.S. Users of iPhone 5 can update to iOS 10. We highly recommend updating to the latest OS version supported.